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Chapter 11
Vectors, Matrices, and Data Arrays

This chapter describes techniques for creating, working with, and 
calculating with Mathcad arrays, including arrays of data you impor
from other sources. While ordinary variables (scalars) hold a single
value, arrays hold many values. The following sections make up th
chapter:

Creating arrays
Overview of techniques for creating arrays, including importing data and 
entering data into an input table.

Accessing array elements
Individual array entries, rows, and columns.

Displaying arrays
How Mathcad displays answers involving arrays.

Working with arrays
Calculating with arrays, graphing arrays, and exporting data. 

Pro Nested arrays
Arrays in which the elements are themselves arrays. 
217
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Creating arrays    

As introduced in “Inserting math” on page 46, one technique of creating an array
use the Matrix  command on the Insert menu to create an array of empty placeholde
and then to enter expressions directly into the placeholders. This technique can on
used for small arrays, but it can be used to create arrays of any kind of Mathcad
expression, not just numbers. This section describes this technique and other app
es for creating arrays of arbitrary size:

■ Using range variables to fill in the elements. This technique is useful when you h
some explicit formula for the array elements in terms of their indices. 

■ Using the File Read/Write component to import data from external files in a var
of formats.

■ Entering numbers manually in a spreadsheet-like input table.

Unlike the Insert Matrix command, however, these procedures can be used only for 
creating arrays of numbers, as opposed to arbitrary math expressions.

Note The effective array size limit depends on the memory available on your system—usually at
1 million elements. In no system is it higher than 8 million elements. 

Insert Matrix command 

To insert a vector or matrix in Mathcad, follow these steps:

■ Click in either a blank space or on a math placeholder.

■ Choose Matrix  from the Insert menu, or 

click  on the Matrix toolbar. A dialog 
box appears, as shown at right. 

■ Enter the appropriate number of elements 
in the text boxes for “Rows” and “Col-
umns.” For example, to create a three-
element vector, enter 3 and 1.

■ An array with blank placeholders appears 
in your worksheet.

Next, fill in the array elements. You can enter any Mathcad expression into the 
placeholders of an array created in this way. Simply click in a placeholder and ty
218  Chapter 11  Vectors, Matrices, and Data Arrays
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number or Mathcad expression. Use the [Tab ] key to move from placeholder to 
placeholder.

Note Arrays created using the Matrix  command on the Insert menu are limited to 100 elements. 

Changing the size of a vector or matrix 

You can change the size of a matrix by inserting and deleting rows and columns

■ Click on one of the matrix elements to 
place it between the editing lines. Mathcad 
begins inserting or deleting with this ele-
ment.

■ Choose Matrix  from the Insert menu. 
Type the number of rows and/or columns 
you want to insert or delete. Then press 
either “Insert” or “Delete.” For example, 
to delete the column that holds the selected 
element, type 1 in the box next to “Columns,” 0 in the box next to “Rows,” and 
press “Delete.”

Note If you insert rows or columns, Mathcad inserts rows below the selected element and inserts 
columns to the right of the selected element. If you delete rows or columns, Mathcad begins 
the row or column occupied by the selected element and deletes rows from that element 
downward and columns from that element rightward. To insert a row above the top row o
column to the left of the first column, first place the entire matrix between the editing lines

Creating arrays with range variables 

As introduced in “Range variables” on page 125, you can use one or more range
variables to fill up the elements of an array. If you use two range variables in an equa
for example, Mathcad runs through each value of each range variable. This is us
for defining matrices. For example, to define a  matrix whose i,jth element is 

, enter the equations shown in Figure 11-1. 

Recall that you enter the range variable operator by pressing the semicolon key (; ) or 

clicking  on the Arithmetic toolbar. You enter the subscript operator by clickin

 on the Matrix toolbar.

The  equation is evaluated for each value of each range variable, for a total o
evaluations. The result is the matrix shown at the bottom of Figure 11-1, with 5 r
and 5 columns. The element in the ith row and jth column of this matrix is .

5 5×
i j+

xi j,

i j+
Creating arrays 219
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Note To be used to define an array element, a range variable can take on only whole-number v

Figure 11-1: Defining a matrix using range variables.

Tip You can also define individual array elements using the subscript operator, as described 
“Accessing array elements” on page 223.

Importing data

Mathcad provides the File Read/Write component to import data from a data file into 
a Mathcad array variable.

Note A component is a specialized OLE object that you insert into a Mathcad worksheet to cre
link between the worksheet and either a data source or another application containing dat
more information on components, including specialized components for linking other 
computational applications dynamically to arrays in a Mathcad worksheet, see Chapter 1
“Advanced Computational Features.”.

You can import data in a variety of file formats, including, among others:

■ Excel (*.XLS)

■ MATLAB  (*.MAT)

■ Lotus 1-2-3 (*.WK*) 

■ ASCII editors (*.DAT, *.CSV, *.PRN, *.TXT)
220  Chapter 11  Vectors, Matrices, and Data Arrays
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Tip Mathcad also provides a number of built-in functions for importing ASCII data files and im
files. See “File access functions” on page 214.

To import data using the File Read/Write component:

■ Click in a blank spot of your worksheet.

■ Choose Component from the Insert menu.

■ Choose File Read or Write from the list and click “Next.” This launches the Fi
Read or Write Wizard. 

■ Choose “Read from a data source” and press “Next” to continue through the Wi

■ Specify the type of data file you want to read. Also enter the path to the data fi
use the “Browse” button to locate it.

■ Press “Finish.” You’ll see the File Read/Write compo-
nent icon and the path to the data file. For example, if 
you specify a data file called DATA.TXT, you’ll see the 
component at right.

In the placeholder that appears, enter the name of the Mathcad variable to which
data from the file will be assigned. When you click outside the component, the dat
is read in and the data is assigned to the Mathcad array variable you entered int
placeholder. Each time you calculate the worksheet, Mathcad re-reads the data 
the file you have specified. Figure 11-2 shows an example of importing data usin
File Read/Write component.

 

Figure 11-2: Importing data from a data file. Whenever you calculate the 
worksheet, the data file is read in.
Creating arrays 221
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To read in a different data file or a different type of data file:

■ Click with the right mouse button on the component and select Choose File from 
the component pop-up menu.

■ In the “Files of type” text box, choose the type of file you’d like to import. Use t
dialog box to browse to the data file, select the data file, and click “Open.”

Tip By default, Mathcad reads in the entire data file and creates an array with the variable nam
provide. To read in only certain rows or columns of a data file, click once on the compone
select it, then click with the right mouse button on the component and choose Properties from 
the pop-up menu. Use the Properties dialog box to specify the row and columns at which to
and stop reading.

Entering data into a table

To get the convenience of a spreadsheet-like interface for entering data, you can 
an array using the Input Table component:

■ Click in a blank spot in your worksheet and choose Component from the Insert 
menu.

■ Select Input Table  from the list and click “Next.” The Input Table component is
inserted into your worksheet. 

■ Enter the name of the Mathcad variable to which the data will be assigned in
placeholder that appears.

■ Double-click the component and enter data into the cells. Each row must hav
same number of data values. If you do not enter a number into a cell, Mathcad in
0 into the cell.

Figure 11-3: Using input tables to create arrays of data.
222  Chapter 11  Vectors, Matrices, and Data Arrays
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Figure 11-3 shows two input tables. Notice that when you create an input table, yo
actually assigning elements to an array that has the name of the variable you en
into the placeholder. 

When you double-click the table, you can edit the values in it. The scroll bars let
scroll through the table. To resize the table, move the cursor to one of these han
along the sides of the region so that it changes to a double-headed arrow. Then
and hold down the mouse button and drag the cursor to change the table’s dimen

Tip You can copy data from an input table as follows: first select some data, then click with the
mouse button on the component and choose Copy from the pop-up menu. You can paste a sing
number from the Clipboard into the table by selecting a cell and choosing Paste from the pop-
up menu. Choosing Paste Table from the pop-up menu overwrites the table with values in th
Clipboard.

Importing once from a data file

You can use an input table to import data a single time from a data file. To do so

■ Insert an input table by following the instructions given above.

■ In the placeholder that appears to the left, enter the name of the Mathcad var
to which this data will be assigned.

■ Click with the right mouse button on the input table so that you see the pop-up m

■ Choose Import .

■ The Read from File dialog box appears. In the “Files of type” text box, choose
type of file you’d like to import. Use the dialog box to browse to the data file a
click “Open.”

The data from the data file appears in your worksheet in a table.

Note Unlike the File Read/Write component, the Import feature of an input table reads the data
when you choose Import , not each time you calculate the worksheet. 

Accessing array elements

You can access all the elements of an array simply by using its variable name, o
can access the elements individually or in groups. 
Accessing array elements 223
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Subscripts 

You access individual elements of a vector or matrix by using the subscript oper
described in “Vector and matrix operators” on page 154. Insert the subscript ope

by clicking  on the Matrix toolbar or by typing [ . To access an element of a vecto
enter one number in the subscript. To access a matrix element, enter two numbe
separated by a comma. In general, to refer to the element in the ith row, jth column of 
matrix M , type M[i,j . To refer to the ith element of a vector, type v[i .

Figure 11-4 shows examples of how to define individual matrix elements and ho
view them.

Figure 11-4: Defining and viewing matrix elements.

Note When you define vector or matrix elements, you may leave gaps in the vector or matrix. F
example, if v is undefined and you define  as 10, then , , and  are all undefined
Mathcad fills these gaps with zeros until you enter specific values for them, as shown in F
11-4. Be careful of inadvertently creating very large vectors and matrices by doing this. N
also that vector and matrix elements by default are numbered starting with row zero and co
zero unless the built-in variable ORIGIN has a value other than zero (see page 225).

You can use this kind of subscript notation in Mathcad to perform parallel calculat
on the elements of an array. See “Doing calculations in parallel” on page 229.

Tip If you want to define or access a group of array elements at once, you can use a range v
in a subscript.

v3 v0 v1 v2
224  Chapter 11  Vectors, Matrices, and Data Arrays
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Accessing rows and columns

Although you can use a range variable to access all the elements in a row or colu
an array, Mathcad provides a column operator for quickly accessing all the elem

in a column. Click  on the Matrix toolbar for the column operator. Figure 11-5
shows how to place the third column of the matrix M  in the vector v. 

Figure 11-5: Extracting a column from a matrix.

To extract a single row from a matrix, transpose the matrix using the transpose ope

(click  on the Matrix toolbar) and then extract a column using the column opera
This is shown on the right-hand side of Figure 11-5.

Changing the array origin

When you use subscripts to refer to array elements, Mathcad assumes the array 
at the current value of the built-in variable ORIGIN. By default, ORIGIN is 0, but you 
can change its value. See “Built-in variables” on page 121 for details.

Figure 11-6 shows a worksheet with the ORIGIN set to 1. If you try to refer to the zeroth
element of an array in this case, Mathcad displays an error message.
Accessing array elements 225
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Figure 11-6: Arrays beginning at element one instead of at element zero.

Displaying arrays

As described in “Formatting results” on page 134, Mathcad automatically display
matrices and vectors having more than nine rows or columns as output tables ra
than as matrices or vectors. Smaller arrays are displayed by default in traditional m
notation. Figure 11-7 shows an example.

Figure 11-7: Displaying results in an output table.
226  Chapter 11  Vectors, Matrices, and Data Arrays
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Note An output table displays a portion of an array. To the left of each row and at the top of ea
column, there is a number indicating the index of the row or column. Click with the right mo
button on the output table and select Properties from the pop-up menu to control whether row
and column numbers appear and the font used for values in the table. If your results exte
beyond the table, a scroll bar appears along the appropriate edge of the table. You can s
through the table using these scroll bars just as you would scroll through any window. 

To resize an output table:

■ Click the output table. You’ll see handles along the sides of the table.

■ Move the cursor to one of these handles so that it changes to a double-headed

■ Press and hold down the mouse button and drag the cursor in the direction you
the table’s dimensions to change.

Tip You can change the alignment of the table with respect to the expression on the left-hand s
the equal sign. Click with the right mouse button on the table, then choose one of the Alignment 
options from the pop-up menu.

Changing the display of arrays

Although matrices and vectors having more than nine rows or columns are autom
cally displayed as scrolling output tables, you can have Mathcad display them as
matrices. To do so:

■ Click on the scrolling output table.

■ Choose Result from the Format menu.

■ Choose Matrix in the “Matrix display style” drop-down box.

■ Click “OK.”

To display all the matrices and vectors of results in your worksheet as matrices (
tables) regardless of their size, click “Set as Default” in the Result Format dialog
before clicking “OK.”

Note Mathcad displays only the first 200 rows or columns in an array displayed as a matrix. An el
is used to indicate that rows and columns are present but not displayed. Although Mathcad
not display these rows or columns, it continues to keep track of them internally.

Changing the format of displayed elements

You format the numbers in the array the same way you format other numerical res
as described in “Formatting results” on page 134. Just click on the displayed array
Displaying arrays 227
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choose Result from the Format menu, and modify the settings there. When you clic
“OK,”  Mathcad applies the selected format to all the numbers in the table, vecto
matrix. It is not possible to format these numbers individually.   

Tip Double-clicking a result array is a shortcut for bringing up the Result Format dialog box.

Copying and pasting arrays

You can copy an array of numbers directly from a spreadsheet or database into Ma
where you can take advantage of its free-form interface and its advanced mathem
tools. Once you’ve performed the necessary computations, you can paste the res
array of numbers back to its source or even into another application.

To copy just one number from a result array, simply click the number and choose Copy 

from the Edit  menu, or click  on the Standard toolbar. Copying multiple numbe
from a vector or matrix result differs depending on whether the array is displayed
matrix or as an output table. See “Formatting results” on page 134 for more inform
on how vector and matrix results are displayed.

To copy a result array displayed as a matrix:

■ Drag-select the array to the right of the equal sign to place the entire array bet
the editing lines.

■ Choose Copy from the Edit  menu. This places the entire array on the Clipboar

■ Click wherever you want to paste the result. If you’re pasting into another app
tion, choose Paste from that application’s Edit  menu. If you’re pasting into a 

Mathcad worksheet, choose Paste from Mathcad’s Edit  menu, or click  on the 
Standard toolbar.

Note You may only paste an array into a math placeholder or into a blank space in a Mathcad 
worksheet. 

When you display array results as a table, you can copy some or all of the numb
from the table and use them elsewhere:

■ Click on the first number you want to copy.

■ Drag the mouse in the direction of the other values you want to copy while hold
the mouse button down.

■ Choose Copy from the Edit  menu.
228  Chapter 11  Vectors, Matrices, and Data Arrays
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To copy all the values in a row or column, click on the column or row number sho
to the left of the row or at the top of the column. All the values in the row or colum
are selected. Then choose Copy from the Edit  menu.

After you have copied one or more numbers from an output table, you can paste
into another part of your worksheet or into another application. Figure 11-8 show
example of a new matrix created by copying and pasting numbers from an output 

Figure 11-8: Copying and pasting results from an output table.

Working with arrays

Once you create an array, you can use it in calculations. There are many operato
functions designed for use with vectors and matrices. See “Vector and matrix opera
on page 154 and “Vector and matrix functions” on page 182 for an overview. Th
section highlights the vectorize operator, which permits efficient parallel calculati
on the elements of arrays. You can also display the values of an array graphical
export them to a data file or another application.

Doing calculations in parallel 

Any calculation Mathcad can perform with single values, it can also perform with
vectors or matrices of values. There are two ways to do this:

■ Iterate over each element using range variables. See for example “Creating a
with range variables” on page 219.

■ Use the vectorize operator, which allows Mathcad to perform the same operatio
efficiently on each element of a vector or matrix.
Working with arrays 229
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Mathematical notation often shows repeated operations with subscripts. For exam
to define a matrix P by multiplying corresponding elements of the matrices M  and N, 
you would write:

Note that this is not matrix multiplication, but multiplication element by element. Iis 
possible to perform this operation in Mathcad using subscripts, but it is much fast
perform exactly the same operation with a vectorized equation.

Here’s how to apply the vectorize operator to an expression like :

■ Select the whole expression by clicking 
inside it and pressing [Space ] until the 
right-hand side is surrounded by the edit-
ing lines. 

■ Click  on the Matrix toolbar to apply 
the vectorize operator. Mathcad puts an 
arrow over the top of the selected expres-
sion.

Properties of the vectorize operator 

■ The vectorize operator changes the meaning of the other operators and functions 
to which it applies. The vectorize operator tells Mathcad to apply the operators
functions with their scalar meanings, element by element. It does not change
meaning of the actual names and numbers. If you apply the vectorize operato
single name, it simply draws an arrow over the name. You can use this arrow
for cosmetic purposes.

■ Since operations between two arrays are performed element by element, all a
under a vectorize operator must be the same size. Operations between an arr
a scalar are performed by applying the scalar to each element of the array. 

■ You cannot use any of the following matrix operations under a vectorize opera
dot product, matrix multiplication, matrix powers, matrix inverse, determinant,
magnitude of a vector. The vectorize operator transforms these operations in
element-by-element scalar multiplication, exponentiation, or absolute value, a
appropriate.

■ The vectorize operator has no effect on operators and functions that require vectors 
or matrices: transpose, cross product, sum of vector elements, and functions
mean. These operators and functions have no scalar meaning.

Tip A number of Mathcad’s built-in functions and operators ordinarily take scalar arguments b
implicitly vectorize arguments that are vectors (one-column arrays): they automatically com
a result element by element, whether you apply the vectorize operator or not. Functions t
implicitly vectorize vector arguments include the trigonometric, logarithmic, Bessel, and 

Pi j, M i j, N i j,⋅=

M N⋅⋅⋅⋅
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probability distribution functions. Operators that implicitly vectorize vector arguments inclu
the factorial, square and nth root, and relational operators. You must continue to use the 
vectorize operator on arrays of other sizes with these functions and operators.

For example, suppose you want to apply the quadratic formula to three vectors 
containing coefficients a, b, and c. Figure 11-9 shows how to do this with the vectoriz
operator. 

Figure 11-9: Quadratic formula with vectors and the vectorize operator.

The vectorize operator, appearing as an arrow above the quadratic formula in Fi
11-9, is essential in this calculation. Without it, Mathcad would interpret  as a 
vector dot product and also flag the square root of a vector as illegal. But with th
vectorize operator, both  and the square root are performed element by eleme

Graphical display of arrays

In addition to looking at the actual numbers making up an array, you can also se
graphical representation of those same numbers. There are several ways to do t

■ For an arbitrary array, you can use the various three-dimensional plot types 
discussed in Chapter 13, “3D Plots.”

■ For an array of integers between 0 and 255, you can look at a grayscale ima
choosing Picture from the Insert menu and entering the array’s name in the 
placeholder. 

■ For three arrays of integers between 0 and 255 representing the red, green, an
components of an image, choose Picture from the Insert menu and enter the arrays’
names, separated by commas, in the placeholder.

a c⋅⋅⋅⋅

a c⋅⋅⋅⋅
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See Chapter 6, “Working with Graphics and Other Objects,” for more on viewing
matrix (or three matrices, in the case of a color image) in the picture operator.

Exporting data

The File Read/Write component allows you to export the values stored in a Math
variable to a variety of file formats, including the following:

■ Excel (*.XLS)

■ MATLAB  (*.MAT)

■ Lotus 1-2-3 (*.WK*) 

■ ASCII editors (*.DAT, *.CSV, *.PRN, *.TXT)

Tip Mathcad also provides a number of built-in functions to export arrays as ASCII data files 
image files. See “File access functions” on page 214.

To export data using the File Read/Write component:

■ Click in a blank spot in your worksheet.

■ Choose Component from the Insert menu.

■ Select File Read or Write from the list and click “Next.” This launches the File R
or Write Wizard. 

■ Choose “Write to a data source” and press “Next” to continue through the Wiz

■ Specify the type of data file you want to write. Also enter the path to the data
you want to write or click the “Browse” button to locate it. 

■ Press “Finish.” You’ll see the File Read/Write compo-
nent icon and the path to the data file. For example, if 
you specify a data file called DATA.TXT , you’ll see the 
component at right.

In the placeholder, enter the name of the Mathcad variable containing the data t
written to the data file. When you click outside the component, all the values in t
array are written to the file you specified. Each time you calculate the worksheet
data file is rewritten. See Figure 11-10 for an example.
232  Chapter 11  Vectors, Matrices, and Data Arrays
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Figure 11-10: Exporting data with the File Read/Write component.

To change the name of the data file being created to or to change the type of file 
created:

■ Click once on the component to select it.

■ Click with the right mouse button on the component and select Choose File from 
the pop-up menu to open the Write to File dialog box.

■ Choose the type of file you’d like to create in the “Files of type” text box. Use 
dialog box to browse to the folder in which the data file will be created and cli
“Open.”

Tip When you display an array as an output table, as described in “Displaying arrays” on page
you can export data directly from the table. Click with the right mouse button on the output t
choose Export  from the pop-up menu, and enter the name of the file that will receive the d
Unlike the File Read/Write component, the output table writes the data only when you cho
Export , not each time you calculate the worksheet.

Nested arrays

Pro An array element need not be a scalar. In Mathcad Professional it’s possible to m
an array element itself be another array. This allows you to create arrays within a

These arrays behave very much like arrays whose elements are all scalars. How
there are some distinctions, as described below.
Nested arrays 233
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Note Most of Mathcad’s operators and functions do not work with nested arrays, since there is
universally accepted definition of what constitutes the correct behavior in this context. Ce
operators and functions are nevertheless useful and appropriate for nested arrays. Functio
enumerate rows or columns, or that partition, augment, and stack matrices, can be applie
nested arrays. The transpose, subscript, and column array operators and the Boolean eq
likewise support nested arrays.

Defining a nested array

You define a nested array in much the same way you would define any array. The
difference is that you cannot use the Matrix  command from the Insert menu when 
you’ve selected a placeholder within an existing array. You can, however, click o
placeholder in an array and type the name of another array. Figure 11-11 shows sever
ways to define a nested array. Additional methods include using a file access fun
such as READPRN in the array of placeholders created using the Insert Matrix comma
and using the programming operators in Mathcad Professional to build up an arr
whose elements are themselves arrays.

Figure 11-11: Defining nested arrays.

Note The display of a nested array is controlled by Display Styles settings in the Result Format d
box (see page 134). You can expand a nested array when the array is displayed in matrix
otherwise, whenever an array element is itself an array, you see bracket notation showing
number of rows and columns rather than the array itself. If the nested array is displayed a
output table, you can see the underlying array temporarily. Click on the array element, then
with the right mouse button and choose Down One Level from the pop-up menu. Choose Up 
One Level from the pop-up menu to restore the array element to non-expanded form.
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